Problem Definition:

A User’s session will become disconnected after remaining idle for more than six hours, and/or a User’s Disconnected Session is logged off after remaining disconnected for more than six hours.  As a consequence, a user who leaves a session unattended/idle for 12 hours will be fully logged out and all applications will be closed.

Cause:

To prepare for Windows Updates, which are installed overnight, and to prevent User’s Desktop Sessions from becoming stale, CloudConnect preconfigures Desktop Hosts with Session Time Limits.  Session Time Limits may need to be extended in certain use cases, or temporarily disabled (for example during an organization’s migration to CloudConnect).This KB Article discusses how to manage Session Time Limits from Group Policy.

Resolution:

Using your “support” account, access the Desktop Host(s) for the organization requiring an adjustment.

From the Start Menu search bar or Run Dialogue Box, type “gpedit.msc”


In the Local Group Policy Editor browse to the following Policy Node in the Tree:

Computer Configuration\Administrative Templates\Window Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits\


The Results Pane will show two Enabled Policies of interest.  They are:

"Set the time limit for disconnected sessions" AND "Set the time limit for active but idle Remote Desktop Services Sessions"


Right Click on the policy you would like to adjust and select “edit.” You can either disable the Policy or adjust the time in Hours to an interval acceptable to your organization’s requirements.

 

Additional Information:

Session Time Limits are unrelated to a User’s Screen locking after 15 minutes of idle time.To adjust this, see KB Article CCT-201410095 – Adjusting the CloudConnect Desktop Idle User Screen Lock Timeout.

Applies To:

Microsoft Windows Desktop Server 2008 R2 Standard

Citrix XenApp 6.5